I’m losing my mind. Our cobra has been active since the beginning of the month. On our insurance website it says our policy is active with no gaps in coverage. None of our doctor’s visits are showing up under our insurance coverage. Whenever the pharmacy tries to run claims they say the policy is terminated. Multiple doctors offices have called me asking if our policy is terminated and those claims are not showing online at all so there isn’t even documentation, I can’t keep track of everything. My daughter has an MRI with contrast on Wednesday and I can’t get preauthorization because the hospital program they’re using says our policy is terminated. They referred it to the preauthorization team but I’m worried it won’t be resolved in time. I’ve contacted the insurance company twice and they keep telling me nothing is wrong, my policy is active, the cobra is all switched over, and the doctors and pharmacy are all doing it wrong. They’re doing exactly what they’ve always done? What should I do? I don’t understand the whole process but it seems like there is some kind of problem with the electronic verification not recognizing that our insurance is active and I don’t know how to get it fixed. I have medication I need to pick up tonight and it’s so expensive there is no way I can pay for it out of pocket and get reimbursed later. I’ve been paying out of pocket since August for meds during the transition and I don’t know how to get them reimbursed and I’m out of money.

See also  Am I committing medical fraud??

submitted by /u/1ncogn1tothrowaway
[comments]